Mac OSX 10.4.10 USB issue

Some months ago, I noticed that my usb ports where not working well on my macbook pro.
I’ve figured out that since the mac osx 10.4.10 update I could’nt mount my external hardrive and my camera. My usb sticks were only working but only with usb1.

After a while on the macs forum I’ve found a way to resolve this.
Here are the steps I used to rollback the usb drivers to mac osx version 10.4.9:

  1. Download the soft Pacifist from here :
    http://www.charlessoft.com
  2. Dowload Applejack software from here :
    http://applejack.sourceforge.net
  3. Download the Mac osx 10.4.9 Update from here (intel in my case) :
    http://search.info.apple.com/?q=Mac+OS+X+10.4.9+Combo+Update&type=kbdload&search=Search&lr=lang_en&search=Go
  4. Install Applejack
  5. Install Pacifist
  6. Run Pacifist
    Mount the 10.4.9 combi disk image and drag the .pkg file to the Pacifist window
  7. Open the folder /System/Library/Extensions in pacifist and select the files IOUSBFamily.kext and IOUSBMassStorageClass.kext
    Click install and reboot
  8. Unplug all your usb devices
  9. When the computer started, reboot again and hold down keys “command” and “S” during reboot
  10. When the command prompt shows up, type applejack
  11. Then select the cleanup cache files by hitting “3″
  12. Select the clean up swapfiles by entering “5″
  13. Hit “r” to reboot your computer
  14. Replug your usb devices and “voilĂ ” ! That worked for me ;)

When osx version 10.4.11 came out, I updated again without any problem. It seems the problem has been solved. So this might only be usefull in case you expecially want to stay with 10.4.10 mac osx version and have this problem.

via Apple support forum


About this entry